Teapot Bot Unavailable
Resolved
Apr 14 at 11:13pm BST
Post Morem
Teapot Bot was down and would not reply to commands due to a domain name change (TeapotLive.net -> XboxStealth.net).
This was causing the api to fail checks and return errors because it was not the right domain.
This issue has been fixed.
Affected services
Updated
Apr 14 at 11:13pm BST
Hotfix deployed successfully, seems to be working fine now.
Will keep monitoring but all systems are currently operational again.
Post mortem will be posted soon.
Affected services
Updated
Apr 14 at 11:11pm BST
Issue Idenfified.
Hotfix deployed.
Affected services
Updated
Apr 14 at 11:04pm BST
Hotfix still did not work... :(
Running API tests now...
Affected services
Updated
Apr 14 at 11:03pm BST
Deploying hotfix #2.
This hotfix uses an older wrangler configuration.
Hopefully this one works.
Affected services
Updated
Apr 14 at 11:02pm BST
Hotfix did not work, attempting to rollback to a different wrangler config instead...
Affected services
Updated
Apr 14 at 11:00pm BST
Hotfix deployed, will be monitoring...
Uploaded bot-teapot (8.18 sec)
Deployed bot-teapot triggers (1.34 sec)
Current Version ID: 33e5db6c-1c1a-4a96-a685-ac2b251cfbc0
Affected services
Updated
Apr 14 at 10:57pm BST
Identified possible cause, creating and deploying a fix when possible.
Affected services
Updated
Apr 14 at 10:47pm BST
Bot code has been rolled back to a previous deployment.
Version: 5a147d5e-9a6d-4290-b38a-3e1dc37ad71d
Originally deployed: 11 days ago
Affected services
Created
Apr 10 at 06:02pm BST
Teapot Discord Bot is currently throwing errors when trying to use commands.
A fallback notice has been placed there while the issue is fixed.
Affected services